Home page

Topic: Engine stall

in Forum: C6 Engines


Already a Member?
Login
Not yet a Member?
Register for Free!

Engine stall (1/2)
 3/27/13 11:36am
yupin1
Standard Member
Send Private Message

Osage Beach, MO - USA

Vette(s):
2005 Coupe, La manz Blue


Joined: 8/1/2012
Posts: 3

I have a 2005 C6 coupe, when driving if I floor the gas the car will fall on it face(so 2 speak), I then get all kinds of system service warnings. If I stop and shut down and restart every thing goes away and runs fine. I have to shut off traction control or go to competitive driving mode and it will stumble the first time I power take off, then it works and runs great after first clean out. Any idea what causes stall?
Our Sponsors help support C6VR
Re: Engine stall (2/2)
 4/9/13 4:24pm
Gray
Standard Member
Send Private Message

, - Canada

Vette(s):
2005 Corvette Convertible, Triple Black


Joined: 6/19/2011
Posts: 1

It sounds like a problem similar problem I had on my 2005 C6. Out of the blue I would get "Reduced Engine Power" and "Service Traction Control System" warnings. I found on a forum somewhere, that it might be the wiring at the MAF sensor that is not right. The computer misdiagnoses the problem. In any case I made sure that the connector at the MAF sensor was making good contact. It appeared to be. Then I made sure each and every wire was pushed into the connector all the way and that all the wires weren't chaffed and contacting any grounds. They weren't. The problem hasn't returned in 2 years so I assume that it was a wire not pushed into the connector properly. 

Good luck with it and if this solution works for you please post a reply so that others may benefit. 


______________
Our Sponsors help support C6VR