Home page

Forum: C6 General Discussion

Topic: What problems have you had with your C6?

What problems have you had with your C6? (1/39)
 11/20/19 4:55pm
Adam Wartell
Standard Member
C6VR Founder
Send Private Message

Eagleville, PA - USA

Vette(s):
1979 "Corvette Red" Coupe


Joined: 5/16/2003
Posts: 2929

I had a suggestion to collect a list of common problems that people have experienced with their C6.  It could be anything from strange tire wear to electrical issues.  Whatever the issue(s), reply to this post with the Year, Model & Engine of your C6 and a brief description of the issue(s) you had, and what the cause and solution were.  



|UPDATED|11/20/2019 1:55:13 PM (AZT)|/UPDATED|
Our Sponsors help support C6VR
Re: What problems have you had with your C6? (2/39)
 11/6/13 1:28pm
Alansvette
Former Member

Send Private Message

Palatine, IL - USA

Vette(s):
2005 convt


Joined: 7/12/2013
Posts: 3

Air bag light on,wiggle the wires under the drivers seat ,the light went off

______________
Re: What problems have you had with your C6? (3/39)
 11/7/13 12:28pm
chuckjosephson
Standard Member
Send Private Message

Supply, NC - USA

Vette(s):
2006 Monterey Red Coupe / 2013 Night Race Blue Metallic Coupe with Cashmere Interior.


Joined: 8/29/2007
Posts: 12

On my 2006 had to have the targa roof replaced through a factory recall due to adhesive letting go.  If you have a 2005 or 2006 and the top creaks, check it out since it could de-laminate and fly off the car.
Re: What problems have you had with your C6? (4/39)
 11/7/13 12:32pm
chuckjosephson
Standard Member
Send Private Message

Supply, NC - USA

Vette(s):
2006 Monterey Red Coupe / 2013 Night Race Blue Metallic Coupe with Cashmere Interior.


Joined: 8/29/2007
Posts: 12

I have a new 2013 coupe with the infotainment option including XM radio and navigation.  The navigation doesn't work within a couple miles of my house or within most developments in Southeastern North Carolina.  I've had the navigation disk checked and I DO have the most current.  Chevrolet claims that this is normal operation.  The local service tech. told me that the technology of the disk based navigation goes back to 1998.  The C7 is satellite based and works better according to him. 
 
I'd appreciate any suggestions in using the C6 navigation.  I currently have my Garmin Nuvi mounted above the factory unit and use that.  I do not use the nav that came with the car.
 
Thanks,
Re: What problems have you had with your C6? (5/39)
 11/7/13 4:23pm
PColarossi
Standard Member
Send Private Message

Lake Orion, MI - USA

Vette(s):
2005 Black Coupe Auto Trans Corsa Sport Exhaust AirRaid Intake Z06 Sway Bars


Joined: 8/10/2006
Posts: 18

My 2005 had the battery replaced under warranty, I replaced the EVAP solenoid this season. The dreaded "Service Traction Control System" light just started, even after the recall was done (it was done about 2 or 3 years ago). But that's about all in the 8 yrs that I've owned it. It's been a great car. I do baby it though. The exhaust was replaced because it was too quiet.... ha! ha!

Pete

Re: What problems have you had with your C6? (6/39)
 11/7/13 7:25pm
chuckjosephson
Standard Member
Send Private Message

Supply, NC - USA

Vette(s):
2006 Monterey Red Coupe / 2013 Night Race Blue Metallic Coupe with Cashmere Interior.


Joined: 8/29/2007
Posts: 12

I'd be interested in what you replaced the exhaust with.  I'm looking for a little more sound, but no droning on the highway, and no head turning under normal acceleration.
 
thanks,
Re: What problems have you had with your C6? (7/39)
 11/8/13 12:07pm
Alansvette
Former Member

Send Private Message

Palatine, IL - USA

Vette(s):
2005 convt


Joined: 7/12/2013
Posts: 3

BB bullets best sound

______________
Re: What problems have you had with your C6? (8/39)
 11/8/13 5:52pm
PColarossi
Standard Member
Send Private Message

Lake Orion, MI - USA

Vette(s):
2005 Black Coupe Auto Trans Corsa Sport Exhaust AirRaid Intake Z06 Sway Bars


Joined: 8/10/2006
Posts: 18

chuckjosephson said: I'd be interested in what you replaced the exhaust with.  I'm looking for a little more sound, but no droning on the highway, and no head turning under normal acceleration.
 
thanks,

Chuck, I had a Corsa sport installed. I did not get the X pipe since I like the burble sound when you back off of it. Sounds great at idle & gives a little more "roar" when accelerating. Absolutely no drone at highway speeds. Should've come that way from the factory.

Pete

Re: What problems have you had with your C6? (9/39)
 11/10/13 6:24pm
fp_vetter07
Standard Member
Send Private Message

Copperas Cove, TX - USA

Vette(s):
07 Machine Silver Coupe 6 sp pattle shift auto 72 Stingray convertible


Joined: 8/6/2008
Posts: 58

Front tire wear on my 2007, they looked good but they were wore down to the threads on the inside edge. Replaced with continental extreme contacts all around much better ride and quit.
Also had a vibration like noise from the right side of the car, found out it was the plastic cover at the base of the windshield by the wipers, dealer replaced it and no more noise.
Had the creaky top but a little silicone on the seals took care of that, mine wasn't included in the recall.
Re: What problems have you had with your C6? (10/39)
 11/11/13 10:55am
CRMGSCoupe
Standard Member
Send Private Message

Camp Hill, PA - USA

Vette(s):
2002 QuickSiver Convertible, 2007 LeMans Blue Coupe, 2010 Crystal Red Metallic Grand Sport Coupe (Heritage Edition). 6 Speed Manual


Joined: 4/7/2008
Posts: 46

Same here. Picked the car up the Monday before Corvettes at Carlisle (2010), and new Corsa Sport exhaust installed that Friday. Same as I had on my 2007. Everybody that hears it comments on how good it sounds.
 
Not the loudest of them all, but absolutely zero drone at all RPM and an awesome sound, including the burble when letting off.
 
 


|UPDATED|11/11/2013 7:55:03 AM (AZT)|/UPDATED|
Re: What problems have you had with your C6? (11/39)
 11/12/13 2:33pm
sharpseadog
Standard Member
Send Private Message

Joined: 7/11/2013
Posts: 11

I have a 2012 C6 Convertible that I bought new exactly 366 days ago.  I now have over 21,000 smiles on it.  Bad battery on delivery.  Had to fight with dealer to replace, finally did, no more problems.  Car has been exceptional.  The GPS system did come with an older DVD, which wouldn't always route correctly.  Dealer replaced and no more problem, although it is a comparatively primitive system.  My 4 year old Garmin is much better, but I do like the heads up display of directions, or I would consider replacing with an aftermarket system.

In June 2013 I installed a Borla "Type S" axle back system.  It is very sweet and mellow.  My best friend with a 2012 coupe went with the touring Corsa.  I like mine much better.  There is no "annoying drone" at steady speeds.  In fact you can barely hear it at all unless you are going up a steep hill or you "step on it".  And unless you really get on it is it still mellow and not the least obnoxious.  I bought my system on-line from Maryland Speed and got an excellent deal and free shipping.  I had it installed by local Chevy dealer who was so accommodating that I was allowed to witness install (and even help a bit).  Great service manager.


______________
Re: What problems have you had with your C6? (12/39)
 11/19/13 11:48am
nc101
Standard Member
Send Private Message

Winter Park, FL - USA

Vette(s):
2006 Monterey Red Convertible


Joined: 12/6/2005
Posts: 6

Problem with gas mileage.

I have just shy of 45,000 miles on my 2006 C6 Convertible and almost overnight I noticed that the Corsa exhaust tips were getting very black.  I have had the O2 sensors changed, canester at the fuel tank changed, plugs are ok, run injector cleaner through the system two times.  Still getting terrible mileage, 12.8 - 14.5 in the city.  Any suggestions??  Thanks for your help. Ned 
Re: What problems have you had with your C6? (13/39)
 11/19/13 8:47pm
jmarctex
Standard Member
Send Private Message


Vette(s):
2011 Grand Sport, Black with Black & Titanium interior


Joined: 10/27/2007
Posts: 21

On my "11" GS I had a crack starting in the transparent roof.  The dealer replaced it under warranty.  The most expensive items have been replacing the front tires at less than 10,000 miles and the rears at 13,000.  I attribute it to a bad factory alignment. I wrongly thought that the darting and tramming was due to the large sticky tires. Had a 4-wheel alignment done after replacing the front tires, non-aggressive settings and again after replacing the rear tires.  The front tires now have 7,000 miles on them and they appear to be doing much better than the originals.  I will have another alignment done at the start of next driving season. 
Re: What problems have you had with your C6? (14/39)
 11/22/13 11:28am
LD2005
Standard Member
Send Private Message

Indianapolis, IN - USA

Vette(s):
2005 DSOM


Joined: 11/13/2013
Posts: 4

chuckjosephson said: I'd be interested in what you replaced the exhaust with.  I'm looking for a little more sound, but no droning on the highway, and no head turning under normal acceleration.
 
thanks,


I have the NXTSTEP exhaust on my of 05 base C6 and i love it, no drone, nice sound 



|UPDATED|11/22/2013 8:28:45 AM (AZT)|/UPDATED|


______________
Re: What problems have you had with your C6? (15/39)
 12/3/13 12:01pm
Will
Standard Member
Send Private Message


Vette(s):
2008 Coupe, Z51 Performance package, Dual Mode Exhaust


Joined: 5/22/2009
Posts: 5

I have a 2005 the auto dimming mirror isn't working. I also had to replace the steering lock mechanism almost$1000.
Re: What problems have you had with your C6? (16/39)
 12/4/13 6:24pm
Corvette Pete
Standard Member
Send Private Message

Crestwood, IL - USA

Vette(s):
2005 Blue coupe


Joined: 9/28/2009
Posts: 9

05 coupe problem shifting into drive on start up. does anybody know of and aftermarket company that sells a shifter or better yet a repair kit for solenoid? 
fuel door doesn't want to stay closed sanded pin and put some lube with teflon on it stay posted seems to be working won't know until may 



______________
Re: What problems have you had with your C6? Shifting Problelms (17/39)
 12/17/13 12:30pm
Fctatesc
Standard Member
Send Private Message

Escondido, CA - USA

Vette(s):
2005 C6 coupe in Magnetic Red


Joined: 10/5/2007
Posts: 9

Having the shift lever lock up when starting is a very common problem with the C6 2005 and 2006 models.  I know people who have spent $800 having the shift unit replaced just to have the same problem.   However, that is not necessary because the problem is easily solved.

A number of people have removed the console cover and snipped the plastic hook from the solenoid that locks the lever into place.  It does not cause diagnostic readings and the problem is solved forever.

There is another way to overcome the problem without removing the console cover and I have done it for 7 years.  If the shift lock will not release upon starting the engine, shut off the engine and put the ignition in accessory mode.  Put your foot on the brake and you will hear the shift lock disengage.  Shift to Neutral and start the engine.  Then you can shift to any gear and proceed.        (If you shift into Park, it will re-engage.)
Re: What problems have you had with your C6? (18/39)
 1/1/14 12:38pm
Garuda
Standard Member
Send Private Message

Vancouver, WA - USA

Vette(s):
2002 Z06 Yellow - Sold 2007 Z06 Black


Joined: 8/14/2013
Posts: 3

I bought my Z06 2007 that the previous owner had replaced the muffler system with a Corsa system.  Very nice sound without the blown away sound of the Borla quad stingers that I had on my 2002 Z06.  If you want a blast of sound, very loud sound, Borla.  If you want a great, deep throated sound that carries well without loudness of the Borla, go Corsa.

R/
Re: What problems have you had with your C6? (19/39)
 1/1/14 12:46pm
Corvette Pete
Standard Member
Send Private Message

Crestwood, IL - USA

Vette(s):
2005 Blue coupe


Joined: 9/28/2009
Posts: 9

thanks I will try the accessory mode when it happens again but will give some serious thought to clipping the nob on solenoid   

______________
Re: What problems have you had with your C6? (20/39)
 1/31/14 1:55am
chucks07C6
Standard Member
Send Private Message

Warner Robins, GA - USA

Vette(s):
2007 Yellow Conv. & 1978 White L48, 4 Speed, Red Int. Low mileage with '82 Collector Ed. Wheels.


Joined: 2/1/2009
Posts: 9

I have a sweek coming from the front of the engine when its running. One friend said that it may be the vibration dampner going bad (separating)??? Any ideas and can I do a R&R myself? Thanks ya'll.
Re: What problems have you had with your C6? (21/39)
 2/11/14 12:14pm
Fctatesc
Standard Member
Send Private Message

Escondido, CA - USA

Vette(s):
2005 C6 coupe in Magnetic Red


Joined: 10/5/2007
Posts: 9

My car is a 2005 C6 with LS2 engine.  Problems are as follows.

1.  The most vexing problem is the "Service Active Handling System" fault and DIC notice.  It occurs randomly and sometimes locks out the cruise control when driving and locks up the shift when shifting to Park.  Then I have to start the car using accessory mode.  The dealer had tried 3 times to fix it but cannot find the cause.  So, I live with it.  Other than above, it seems to have no affect on driveability.   Sometimes, it goes away when restarting the car.

2.  Frequently, the shift lock locks the car in "Park".   When that happens, I have to use accessory mode and start the car in Neutral, then shift to D or R.   Many owners have this problem and have resorted to cutting the shift lock pawl.  I have not done that because I don't feel comfortable removing the console cover when I can simple use accessory mode to bypass the problem. 

3.   Recently, at 47,000 miles, I had to have the differential seal replaced on the drivers side axel.  Minor problem.   I also replaced the rear sway bar links.  They were very loose and one was dry and scratchy.  Haven't done the front yet.

4.  Tire wear is significant.  When alignment is set to "street use" specs,  I get severe wear on the inside edge of the front tires.   I got 21,500 miles on my last set.  I am attempting to get that corrected before buying another set of tires.

5.  Replaced all break pads at about 43,000 miles.
Re: What problems have you had with your C6? (22/39)
 5/30/14 5:02pm
71stngr
Standard Member
Send Private Message

Willits, CA - USA

Vette(s):
1971, C3, 454 black&blue, coupe, blue real flames. 2005, C6, 6.0L Red, coupe, chrome wheels 2014, C7, Syber Greay, pearl white stripes, chrome wheels


Joined: 3/11/2013
Posts: 8

05' C6 Coupe, LS2; I always use Chevron gas with techron, and the last 4 times I filled it up, it would cut off with only 8 gallons or less, and acted like it was full, but it would only show 1/2 full on the gauge.  It was consistent, and I couldn't force another ounce into the tank.  A corvette shop recommended I bring it in and he would drop the rear axel and the right side tank to change out a crossover pump that feeds the separated tanks, and that was the problem.  I read on a corvette forum of people using "Sea Foam" in the system to correct this problem.  So, before I spent the money to overhaul the fuel system, I tried the Sea Foam.  I added it when I filled up, and again it only let me have a half tank, but when I ran the 16oz can thru the system, ran the tank down low, and refilled it, it filled all the way, and the gauge read full.  It's worked out for several months now, and haven't had the problem since, and I'm using the same gas station and same pump.

______________
Re: What problems have you had with your C6? (23/39)
 6/3/14 11:49am
brocky3
Standard Member
Send Private Message

jackson, NJ - USA

Vette(s):
Victory Red 2009 Coupe with 2LT package with chrome wheels


Joined: 12/5/2012
Posts: 3

2009 Coupe. Manual Trans. At 8k miles, shifter would hang up between 1st and 2nd. Had to jiggle shifter and pull hard to get it into 2nd. Brought it to dealer, fixed under warranty. Said it needed 'adjusting'.
Re: What problems have you had with your C6? (24/39)
 6/4/14 8:25am
GJHZ06
Standard Member
Send Private Message


Vette(s):
2012 Supersonic Blue Z06 2013 Velocity Yellow Grand Sport Coupe


Joined: 7/20/2009
Posts: 3

Body Control Module replacement.  There is also a sensor for the traction control system and transmission that may need to be replaced.  Our 2007 Coupe began exhibiting these same symptoms and was finally corrected with the total replacement of the BCM...$450-500 repair.



______________
Re: What problems have you had with your C6? (25/39)
 6/4/14 10:28am
jrhall55
Standard Member
Send Private Message

Brawley, CA - USA

Vette(s):
2000 C5 convertible, and a 2005 C6 Coupe


Joined: 10/4/2012
Posts: 23

In regards to the fuel door not closing,, I found a spring inside the left rear interior panel where the cable release is for the fuel door. Replaced the spring with heavier one and works perfect... to try it at first I used a rubber band... 
 
 
For those of you talking exhaust,, I use magna flow stainless system, love the sound, no drone, and did the job myself. I have owned my C6 2005 coupe for 4 years now and have experienced several change problems.. with he help of this web site and other people been able to take care of everything. The wiggling the wires under the seat for the seat belt or air bag lite boggles me, but works most of the time... Love my car,, if I can be of help, please ask..


______________
Re: Problems shifting to 2nd gear (26/39)
 6/10/14 2:01pm
FrankM
Standard Member
Send Private Message

Williston Park, NY - USA

Vette(s):
2008 C6 Coupe, LS3, Blk/Blk, 6M Z51, 3LT


Joined: 10/10/2006
Posts: 19

Are you aware of CAGS (Computer Aided Gear Selection)? To help GM meet fleet fuel economy standards, CAGS locks out gears 2 and 3 during casual acceleration and forces shifting from first directly to fourth gear. Did the service people mention if your problem was related to CAGS?
 You can buy an aftermarket kit which can bypass CAGS so that you may shift to 2nd and 3rd under any rates of acceleration. Its installed under the car at a wiring connector.
Incidentally, in the C7 which has a 7-speed manual transmission, CAGS will force shifting from 2nd to 5th under casual acceleration.


______________
2008 C6 Coupe, LS3, Blk/Blk, 6M Z51, 3LT


Re: What problems have you had with your C6? (27/39)
 6/17/14 10:40pm
Garuda
Standard Member
Send Private Message

Vancouver, WA - USA

Vette(s):
2002 Z06 Yellow - Sold 2007 Z06 Black


Joined: 8/14/2013
Posts: 3

There is also a circuit breaker change that you can do to block out the 1st to 4th system.  I got mine online but I'm sorry I have forgotten the name of the supplier.  You may be able to google it.  I have a 2007 Z06 and it worked fine on the car.    I had the same thing done to my 2002 Z06 by a dealer in Portland.  I think they did some type of electrical bypass to that one.
Re: What problems have you had with your C6? (28/39)
 6/25/14 11:00pm
boilerbob
Standard Member
Send Private Message

Joined: 6/25/2014
Posts: 6

Both sun visor mirror covers just popped off. The plastic hinge pins cracked on their own. $500 to replace the visors. Cheap part for a $70k car. Found a $40 aftermarket cover that works ok.
Re: What problems have you had with your C6? (29/39)
 6/28/14 11:09am
LOHpilot
Standard Member
Send Private Message

Ocean View, DE - USA

Vette(s):
2013 Corvette Convertible Night Race Blue with 3LT Ebony interior


Joined: 6/28/2014
Posts: 17

In June of 2013, after 3 months of ownership, I had a Low Oil Pressure message on the info center also will zero oil pressure gauge indication.  I did some on line work to find out that there is a GM tech directive on all LS engines 2007 and later to have the oil pressure sensor fail.  The oil pan needs to be dropped and replace the sensor.  Work covered under warranty.  Job would normally be $1,300 out of pocket.

______________
Re: What problems have you had with your C6? (30/39)
 7/1/14 12:46pm
brocky3
Standard Member
Send Private Message

jackson, NJ - USA

Vette(s):
Victory Red 2009 Coupe with 2LT package with chrome wheels


Joined: 12/5/2012
Posts: 3

Wasn't the 2nd gear skip. Had trouble going into 2nd even when I had my foot in it.
Re: What problems have you had with your C6? (31/39)
 7/2/14 6:17pm
71stngr
Standard Member
Send Private Message

Willits, CA - USA

Vette(s):
1971, C3, 454 black&blue, coupe, blue real flames. 2005, C6, 6.0L Red, coupe, chrome wheels 2014, C7, Syber Greay, pearl white stripes, chrome wheels


Joined: 3/11/2013
Posts: 8

Where did you get your your $40 replacement mirrors?  Mine are shot as well, the originals are very fragile.  Thanks

______________
Re: What problems have you had with your C6? (32/39)
 7/8/14 11:53am
boilerbob
Standard Member
Send Private Message

Joined: 6/25/2014
Posts: 6

Bought the Ebay units @$40. See http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&vxp=mtr&item=141337627549

Just like OEM. Probably a Chinese copy but no doubt that's where GM got the originals. Used Harbor Freight pick. http://www.harborfreight.com/4-piece...set-66836.html

Put hook behind spring clip, place cover hinge pin next to spring clip and pull until the hinge pin slips into spring clip. You have to pull hard to get enough clearance. 

Re: What problems have you had with your C6? (33/39)
 7/8/14 12:13pm
Atchafalaya
Standard Member
Moderator
Send Private Message

Joined: 2/9/2010
Posts: 70

seems simple enough...........thanks
Re: What problems have you had with your C6? (34/39)
 7/8/14 6:02pm
71stngr
Standard Member
Send Private Message

Willits, CA - USA

Vette(s):
1971, C3, 454 black&blue, coupe, blue real flames. 2005, C6, 6.0L Red, coupe, chrome wheels 2014, C7, Syber Greay, pearl white stripes, chrome wheels


Joined: 3/11/2013
Posts: 8

great, I have the pick set, so I'll order the mirrors....

Thanks for the info.



______________
Re: What problems have you had with your C6? (35/39)
 7/15/14 4:01pm
nc101
Standard Member
Send Private Message

Winter Park, FL - USA

Vette(s):
2006 Monterey Red Convertible


Joined: 12/6/2005
Posts: 6

Earlier this year I posted that I was having a problem with my 2006 C6 Convertible.  Bad gas mileage and some oil usage.  Guess what, this past Spring I was driving along and the check oil light came on...I went home and checked the oil and it was down over a quart and I still had over 45% left on the oil change gauge.  Usually change oil every 4,000 miles since I have such low mileage on the car (46,000).
Took the car to my very experienced mechanic and found that the rings had failed, stacked, on three cylinders.  
My new 3 year warranty (7 year warranty expired in October 2013)  would not pay for the repair and I had to have the engine rebuilt at my expense.  There was a bulletin that came out in 2008 stating that there was a potential problem with the rings and pistons and that they should be replaced. Never new about the bulletin, too bad since than I had a 7 year warranty that would have covered the repair.
Just be aware!!  This covers years 2005 - 2007.   
Re: What problems have you had with your C6? (36/39)
 7/15/14 7:54pm
blueflame54
Standard Member
Send Private Message

Madison Heights, VA - USA

Vette(s):
1954 Roadster 1966 Convetible 4 spd 2006 Coupe 6 spd


Joined: 6/17/2010
Posts: 1

I have been having the same problem with my '06.... Will try Sea Foam..
Thank you for your post. Thumbs Up


______________
Re: What problems have you had with your C6? (37/39)
 8/15/14 10:46pm
patrick
Standard Member
Send Private Message

Joined: 8/14/2014
Posts: 1

My HUD does no activate up ignition. Only is I depress the down arrow foe 1.5 seconds, then the up arrow for 3 seconds! If I count more or less than 15 seconds it won't come up. And only one try. What's up?
Shift lock problems (38/39)
 11/20/19 2:49pm
NJDevil
Standard Member
Send Private Message

Woodbine, GA - USA

Vette(s):
2008 Coupe


Joined: 11/14/2019
Posts: 2

I had a shift lock problem at about 40k miles on my 2008 coupe. A few times I could not come out of park. I went to accessory mode and was able to start and shift. However, later on I had problems going from drive to park. The shifter would not go past neutral from drive. Couldn't put transmission into park and had to disconnect battery to shut car off. I ended up having to take the center console apart to get access to the shift lock and manually disengage the shift lock. This happened several times after and I ended up having to replace the shifter/shift lock assembly. Works fine now.

 

Re: What problems have you had with your C6? (39/39)
 11/20/19 5:55pm
Motorscooter
Standard Member
Send Private Message

Ellicott City, MD - USA

Vette(s):
2005 Daytona Sunset Orange Metallic Convertible. Auto. Stock. Daily driver with 98K miles so far. Original owner.


Joined: 1/22/2019
Posts: 6

My 2005 Sunset Orange Convertible with over 100K on the odometer developed the gear shift lock issue at about 90K miles.  When starting I couldn't move the shift out of park.  I read about a bunch of solutions from "live with it" to several different kinds of mechanical fixes.  One solution has worked for me.  Shut down, then when restarting keep your foot on the brake and keep pressing the start button for a few seconds.  Sometimes I've had to restart a few times but it has always released eventually.

The navigation disk drive and the CD player stopped working around 2010.

Other than that the gas cap warning kept coming on when the car was new.  That entailed having the entire rear removed to get to a sensor at the top of the gas tank.  Warranty covered that one.  The passenger airbag warning keeps popping up every few years.  But it stops on its own.  

And, most annoying is that in one step of the top going up or down I have to reach back and pull on a part of the roof to keep it from rubbing.  I was told that to adjust the mechanism they'd have to take the top completely apart.  I.E. $$$$.

The car is stock except for color matching door handles and the addition of the factory issued front license plate holder after getting a warning from a state trouper.

Our Sponsors help support C6VR